We are still having issues with a couple of the mods that are enabled now, on the 5.3 server build.  Please continue to be patient as we resolve the glitches as quickly as we can.

Petz and a couple of other mods are temporarily disabled as they completely break due to some incompatibility issues with other mods that only surfaced after we upgraded everything to 5.3 compatible versions.  We will work on resolving these mods after the other ones are solved first.

Categories:

Tags:

Comments are closed

About This Site

Yeticraft seeks to make learning fun through technology.